Resolved
Since 10.50 UTC, some service data sources in 4 of our regions have not been reporting data, causing queries to those sources to fail. A fix was deployed, and all queries are working as expected now.
Monitoring
We've deployed the fix. We are monitoring that everything is back to normal
Identified
We've identified the problem and we are deploying fix
Investigating
Since 10.50 UTC, the service datasources from all the regions started to not report data and also queries to those service datasources are failing.