Resolved
The issue was fully resolved at 15:10 UTC
Monitoring
We've applied a fix that's resolved the situation. We're still monitoring.
Identified
We're taking longer to fulfill requests to aws-us-east-1 across the board. We've identified the cause and are working on a fix.
Investigating
We're investigating error reports of users accessing our UI for workspaces in aws-us-east-1. The region selector seems to be affected too.