Resolved
Service is back to normal.
Monitoring
Service is back, we're still monitoring the region.
Full degradation occurred from ~11:20-11:25UTC.
Investigating
We're currently experiencing a degradation across the entire region but Kafka. We're investigating the root cause.