The platform is back to normal and everything is stable
Resolved
Monitoring
We've identified the root cause and applied the fix, and latencies are back to normal now
Investigating
We're investigating an increase in latencies in the region