Resolved
We've deployed a fix to improve the stability of the platform. Sorry for the inconvenience
Monitoring
We deploying a fix to improve the stability of the platform
Investigating
We are seeing a degradation of the performance in the public AWS US EAST cluster