Resolved
The incident is now resolved.
Monitoring
The issue was caused due to a peak of heavy queries causing OOM in one of the replicas. This is now fixed and everything should be working properly now. We'll keep monitoring.
Investigating
We're investigating an issue causing degradation on GCP europe-west2 public-a cluster. We'll keep you updated as soon as we find the issue.