Monitoring
The fix is rolled out, and everything is back to normal. We keep monitoring to ensure everything works as expected.
Identified
The root cause was identified. A major traffic spike hit an endpoint with synchronous metadata database queries, affecting some applications' performance and causing a cascading database failure, which has already recovered. A fix is being deployed and should restore the region's performance.
Investigating
We detected some degradation in the eu-west-1 region due to a metadata database failure. The team is looking into it, and we'll update you with more information soon.